summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-06-18 11:05:18 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2014-06-18 11:05:18 +0200
commitfcbe00774f070be2dcbdc10b07678e02bf2f094b (patch)
tree39311682a3eb9dcb0b8f5aca7d451dbc19147b74 /test/Makefile.am
parent4b29f07c2a14a14377cf23ed3892498558787907 (diff)
Add unittest for binary size of package header (should fail on 64 bit).
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c58c537..24ca765 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,4 @@
-TESTS = multiplexer
-# pseudoclass
+TESTS = multiplexer package
check_PROGRAMS = $(TESTS)
@@ -7,3 +6,7 @@ multiplexer_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"multiplexer\" \
-I.. -I../../lib $(PQ_CFLAGS) -I$(top_srcdir)/hugin
multiplexer_LDFLAGS = $(CPPUNIT_LIBS) $(PTHREAD_LIBS)
multiplexer_SOURCES = test.cc test_multiplexer.cc
+
+package_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"package\"
+package_LDFLAGS = $(CPPUNIT_LIBS)
+package_SOURCES = test.cc test_package.cc